const regex = /(\S)\b((?:S\d+)?EP?\d+\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\S)\\b((?:S\\d+)?EP?\\d+\\b)', 'gm')
const str = `克隆人战争S01E02 2008.720p-CMCT`;
const subst = `$1 $2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);