re = /(\S)\b((?:S\d+)?EP?\d+\b)/m
str = '克隆人战争S01E02 2008.720p-CMCT'
subst = '$1 $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result