package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:http:\/\/|www\.)?(\w+\.(?:com|net)\/directory)$`)
var str = `example.com/directory
http://example.com/directory
www.example.com/directory`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}