re = /^(?:http:\/\/|www\.)?(\w+\.(?:com|net)\/directory)$/m
str = 'example.com/directory
http://example.com/directory
www.example.com/directory'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end