# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/title="[\s\S]*?"//;t' <<< "<a href=\"#\" title=\"<table border=\"0\" width=\"100%\" cellspacing=\"0\" cellpadding=\"0\">
<tbody>
<tr>
<td colspan=\"2\" align=\"center\" valign=\"top\"></td>
</tr>
<tr>
<td valign=\"top\" width=\"50%\">
table content
</td>
<td valign=\"top\" width=\"50%\">
table content
</td>
</tr>
</tbody>
</table>\">Link Title</a>"