// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"title="[\s\S]*?""#).unwrap();
let string = "<a href=\"#\" title=\"<table border=\\"0\\" width=\\"100%\\" cellspacing=\\"0\\" cellpadding=\\"0\\">
<tbody>
<tr>
<td colspan=\\"2\\" align=\\"center\\" valign=\\"top\\"></td>
</tr>
<tr>
<td valign=\\"top\\" width=\\"50%\\">
table content
</td>
<td valign=\\"top\\" width=\\"50%\\">
table content
</td>
</tr>
</tbody>
</table>\">Link Title</a>";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}