using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^'(\d)+':\s+(.+)$";
string input = @"'1': '-'
'2': CompanyA; 100EUR/Std
'3': Company2; 100EUR/Std
'4': Company B ; 155EUR/Std";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}