$re = '/^\'(\d)+\':\s+(.+)$/mx';
$str = '\'1\': \'-\'
\'2\': CompanyA; 100EUR/Std
\'3\': Company2; 100EUR/Std
\'4\': Company B ; 155EUR/Std';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);