re = /^'(\d)+':\s+(.+)$/mx
str = '\'1\': \'-\'
\'2\': CompanyA; 100EUR/Std
\'3\': Company2; 100EUR/Std
\'4\': Company B ; 155EUR/Std'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end