const regex = /^(\+|1\s?)?(\([0-9]{3}\)\s?|[0-9]{3}\-?)([0-9]{3}\-?|[0-9]{3}\s?)[0-9]{4}$/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\+|1\\s?)?(\\([0-9]{3}\\)\\s?|[0-9]{3}\\-?)([0-9]{3}\\-?|[0-9]{3}\\s?)[0-9]{4}$', 'img')
const str = `1 555 555 5555
1 456 789 4444`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}