// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(expression=["|'].*?>)(.*?["|'])"#).unwrap();
let string = "expression=\"9a / 3b - 10c\" > foo=\"67 + 34\" // The regular expression should only find up until expression=\"99 / 32 - 10\" and no further
expression=\"x > 10\" foo=\"67 + 34\" // Correct find";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}