# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\.\K\h*[Jj]ack,? is[^.\n]*\.$/ [TRIM]/gm;t' <<< "Jack is the tallest person.
and Jack is the one who said, let there be fries.
There are mirrors. And Jack is there to be suave.
There are dogs. And jack is there to pat them. Very cool.
Jack is your lumberjack. Jack, is super awesome.
Whereas Jack is, for the whole summer, sound asleep. Zzzz
'Jack is so cool!' Jack is cool. Jack is also cold."