using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.\K\h*[Jj]ack,? is[^.\n]*\.$";
string substitution = @" [TRIM]";
string input = @"Jack is the tallest person.
and Jack is the one who said, let there be fries.
There are mirrors. And Jack is there to be suave.
There are dogs. And jack is there to pat them. Very cool.
Jack is your lumberjack. Jack, is super awesome.
Whereas Jack is, for the whole summer, sound asleep. Zzzz
'Jack is so cool!' Jack is cool. Jack is also cold.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}