$re = '/(\d{1,3})(?=(?:\d{3})+(?:\.\d*)?$)/m';
$str = '1
12
123
1234
12345
123456
1234567
12345678
123456789
1234567890';
$subst = "$1,";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;