re = /([0-2][0-9]|3[0-1])\-(0[1-9]|1[0-2])\-\d{4}/m
str = '31-12-1999
31-13-1999 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end