#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)TdxBar[\s\S]+TAction"
Local $sString = "pnlVisao: TPanel;" & @CRLF & _
"tbToolBar: TdxBar;" & @CRLF & _
"btnCancelar: TButton;" & @CRLF & _
"actAbrir: TAction;" & @CRLF & _
"pnlVisao: TPanel;" & @CRLF & _
"tbToolBar: TdxBar;" & @CRLF & _
"btnCancelar: TButton;" & @CRLF & _
"actAbrir: TAction;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")