use strict;
my $str = 'Lorem ipsum dolor sit amet, consetetur sadipscing (elitr, sed diam nonumy eirmod tempor invidunt, ut labore, et dolore magna aliquyam erat), (sed diam) voluptua. (At, vero) eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet.';
my $regex = qr/(?:\([^),]*|\G(?!^))\K,([^),]*)/p;
my $subst = '+$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";