re = /(?:\([^),]*|\G(?!^))\K,([^),]*)/
str = 'Lorem ipsum dolor sit amet, consetetur sadipscing (elitr, sed diam nonumy eirmod tempor invidunt, ut labore, et dolore magna aliquyam erat), (sed diam) voluptua. (At, vero) eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet.'
subst = '+$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result