#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?![\W_])((?:([\w-]{2,})\.?){1,})(?<![\W_])@(?![\W_])(?=[\w.-]{5,})(?=.+\..+)((?:([\w-]{2,})\.?){1,})(?<![\W_])$"
Local $sString = "# Valid" & @CRLF & _
"test@gm.com" & @CRLF & _
"test@gmail.com" & @CRLF & _
"aa-test@gmail.com" & @CRLF & _
"aa_test@gmail.com" & @CRLF & _
"aa.test@gmail.com" & @CRLF & _
"aa1test@gmail.com" & @CRLF & _
"aa1.test@gmail.com" & @CRLF & _
"aa1-test@gmail.com" & @CRLF & _
"1test@gmail.com" & @CRLF & _
"test@gmail.co.in" & @CRLF & _
"aa-test@gmail.co.in" & @CRLF & _
"aa_test@gmail.co.in" & @CRLF & _
"aa.test@gmail.co.in" & @CRLF & _
"aa1test@gmail.co.in" & @CRLF & _
"aa1.test@gmail.co.in" & @CRLF & _
"aa1-test@gmail.co.in" & @CRLF & _
"1test@gmail.co.in" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"# Invalid " & @CRLF & _
"test@gmail" & @CRLF & _
".test@gmail.com" & @CRLF & _
"-test@gmail.com" & @CRLF & _
"_test@gmail.com" & @CRLF & _
"tes.t@gmail.com" & @CRLF & _
"t.e.st@gmail.com" & @CRLF & _
"t.-.est@gmail.com" & @CRLF & _
".test.@gmail.com" & @CRLF & _
"test.@gmail.com" & @CRLF & _
"test.@.gmail.com" & @CRLF & _
"test@.gmail.com" & @CRLF & _
"test@.gmail.com." & @CRLF & _
"test@gmail.com."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")