const regex = /^(10|11|12|[0]{1}[1-9]{1})\/[0][1-9]|[10-31]?/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(10|11|12|[0]{1}[1-9]{1})\\\/[0][1-9]|[10-31]?', '')
const str = `09/10
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}