re = /\s+ \w+\s+={37}\s+Table tablespaces do not match\. Destination : SUM_DEMO_(\w+) Source : SFDEV_(\1)/
str = ' ADM_RPT_COL
=====================================
Table tablespaces do not match. Destination : SUM_DEMO_STARS_DAT Source : SFDEV_STARS_DAT
ADM_RPT_HDR
=====================================
Table tablespaces do not match. Destination : SUM_DEMO_STARS_DAT Source : SFDEV_STARS_DAT
ADM_USER_PREF
=====================================
Table tablespaces do not match. Destination : SUM_DEMO_STARS_DAT Source : SFDEV_INFMT_DAT '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end