const regex = /([^!()[]]*)(\[[^]]+\])\(([^.)]+)(\.md)?\)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^!()[]]*)(\\[[^]]+\\])\\(([^.)]+)(\\.md)?\\)', 'g')
const str = `Some [word](link1) which [looks](link2) like this`;
const subst = `\1(\2.html)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);