use strict;
my $str = 'Some [word](link1) which [looks](link2) like this';
my $regex = qr/([^!()[]]*)(\[[^]]+\])\(([^.)]+)(\.md)?\)/p;
my $subst = '\\1(\\2.html)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";