$re = '/([^!()[]]*)(\[[^]]+\])\(([^.)]+)(\.md)?\)/';
$str = 'Some [word](link1) which [looks](link2) like this';
$subst = "\1(\2.html)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;