use strict;
my $str = 'isDraggingObject : True
id : afbbdeb7-9fd4-4b53-ab17-742809154ba9
condition : {or, matches System.Object[] (?i)(^.*?host failure
alert.*?www\\.jennycraig\\.com\\.au.*?$), matches System.Object[]
(?i)(^.*?\\bwarning\\b.*?www\\.jennycraig\\.com\\.au.*?$)}
catch_all : False
advanced_condition : {}
actions : {route PVG22KK, severity warning}
isDraggingObject : True
id : 3b5aa785-b854-4e43-900a-225da5786a27
condition : {or, matches System.Object[]
(?i)(^.*?\\bcritical\\b.*?www\\.jennycraig\\.com\\.au.*?$)}
catch_all : False
advanced_condition : {}
actions : {severity critical, route PVG22KK}
**isDraggingObject : True
id : a8420998-fbca-486b-9ff7-d03b9e16536e
condition : {or, matches System.Object[] (?i)(^.*?\\bcritical\\b.*?www\\.jennycraig\\.com$),
matches System.Object[] (?i)(^.*?\\bcritical\\b.*?locations\\.jennycraig\\.com)}
catch_all : False
advanced_condition : {}
actions : {severity critical, route PW0VV83}**';
my $regex = qr/(?<event>^.\S*[^\n<]*(?:(?:<(?!)|\n(?!$))[^\n]*)*(?:|\n$|\z))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}