import Foundation
let pattern = #"(?<event>^.\S*[^\n<]*(?:(?:<(?!)|\n(?!$))[^\n]*)*(?:|\n$|\z))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
isDraggingObject : True
id : afbbdeb7-9fd4-4b53-ab17-742809154ba9
condition : {or, matches System.Object[] (?i)(^.*?host failure
alert.*?www\.jennycraig\.com\.au.*?$), matches System.Object[]
(?i)(^.*?\bwarning\b.*?www\.jennycraig\.com\.au.*?$)}
catch_all : False
advanced_condition : {}
actions : {route PVG22KK, severity warning}
isDraggingObject : True
id : 3b5aa785-b854-4e43-900a-225da5786a27
condition : {or, matches System.Object[]
(?i)(^.*?\bcritical\b.*?www\.jennycraig\.com\.au.*?$)}
catch_all : False
advanced_condition : {}
actions : {severity critical, route PVG22KK}
**isDraggingObject : True
id : a8420998-fbca-486b-9ff7-d03b9e16536e
condition : {or, matches System.Object[] (?i)(^.*?\bcritical\b.*?www\.jennycraig\.com$),
matches System.Object[] (?i)(^.*?\bcritical\b.*?locations\.jennycraig\.com)}
catch_all : False
advanced_condition : {}
actions : {severity critical, route PW0VV83}**
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)