$re = '/.*[)]$/m';
$str = 'x=main2.addMenu(\'Edit\')
x=main2.addMenu(\'Edit2\')
x=main2.addMenu(\'Edit3\')
x=main2.addMenu(\'Edit4\')';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);