re = /.*[)](\r?\n|$)/
str = 'x=main2.addMenu(\'Edit\')
x=main2.addMenu(\'Edit2\')
x=main2.addMenu(\'Edit3\')
x=main2.addMenu(\'Edit4\')'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end