// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*@(\S+)").unwrap();
let string = "From: <email@example.com> FROM name fails
Closed (fixed)
Project:
SMTP Authentication Support
Version:
6.x-1.0-beta5
Component:
Code
Priority:
Normal
Category:
Bug report
Assigned:
José San Martin
Reporter:
goose2000
Created:
July 8, 2008 - 12:54
Updated:
October 5, 2012 - 19:01
Log in or register to update this issue
Jump to:
Most recent attachment
Hi, my development site is running on IIS with SMTP server. Mail is working fine when creating new users or getting a password reset. I have built a webform and upon submitting I'll get this error:
* warning: mail() [function.mail]: SMTP server response: 501 5.5.4 Invalid Address in C:\\Inetpub\\wwwroot\\BHI_dev\\includes\\mail.inc on line 193.
* Unable to send e-mail. Please contact the site admin, if the problem persists.
The address I use in my testing are in fact completely valid. Seems like webform is not playing nice with the core somehow. Further ideas?
Using Drupal 6.2.
Thanks.
Files:
Comment File Size Author
#25 smtp_279836.patch 694 bytes scttnlsn
#13 smtp_module_name_patch_279836_01.patch 724 bytes franz
#6 smtp_module_name_patch_279836_01.patch 724 bytes rfay
Comments
goose2000’s picture
Comment #1goose2000 CreditAttribution: goose2000 commented 8 years ago
Priority: Critical » Minor
This seems to be an IIS SMTP issue only. See here:
http://drupal.org/node/33967
Easy work around is to have no 'name' text , just the email address when you configure webform.
Think it may still be fixable at the code? I set it to 'minor' now.
Working great, one of the best modules around.
Log in or register to post comments
quicksketch’s picture
Comment #2quicksketch CreditAttribution: quicksketch commented 7 years ago
Title: Email Invalid Address » \"Name\" <email@example.com> FROM name fails
Project: Webform » SMTP Authentication Support
Version: 6.x-2.1.1 » 6.x-1.0-beta3
Moving to the SMTP module.
To summarize, Webform users have not been able to send e-mails when using the SMTP module and the FROM e-mail addresses are formatted as \"First Last\" <email@example.com>. The name is properly mime_header_encoded when necessary.
Any users experiencing this issue, please update with the version of SMTP module you're using.";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}