# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\\/b-\d+)(.+)(?!View\%20All)//gm;t' <<< "http://www.foo.com/bar/b-12312903?sName=View%20All
http://www.foo.com/bar/b-832173712873?sName=View%20All
http://www.foo.com/bar/b-1208313109283129
http://www.foo.com/bar/b-2198123371239489?adCell=W3"