import Foundation
let pattern = #"(\/b-\d+)(.+)(?!View\%20All)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://www.foo.com/bar/b-12312903?sName=View%20All
http://www.foo.com/bar/b-832173712873?sName=View%20All
http://www.foo.com/bar/b-1208313109283129
http://www.foo.com/bar/b-2198123371239489?adCell=W3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)