const regex = /<td.*?class="MID"[^>]*[\s\S]*?<\/td>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<td.*?class="MID"[^>]*[\\s\\S]*?<\\\/td>', '')
const str = `<td width="33%" align="left" class="MID">
<a href="ShowDOTCoByState.cfm?STATE=US&PHY_ST=IA">IOWA</a>
</td>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}