#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-z][a-z0-9_\.]{5,32}@[a-z0-9]{2,}(?:\.[a-z0-9]{2,4}){1,2}$"
Local $sString = "longvu.kiemtien@gmail.com" & @CRLF & _
"00tk.quangphuong@gmail.com" & @CRLF & _
"nguyentangchien@mail.com" & @CRLF & _
"samsam052001@" & @CRLF & _
"buithianhthu2612@gmail.com" & @CRLF & _
"khanhhn.games@gmail" & @CRLF & _
"hienxsktdakla"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")