package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z][a-z0-9_\.]{5,32}@[a-z0-9]{2,}(?:\.[a-z0-9]{2,4}){1,2}$`)
var str = `longvu.kiemtien@gmail.com
00tk.quangphuong@gmail.com
nguyentangchien@mail.com
samsam052001@
buithianhthu2612@gmail.com
khanhhn.games@gmail
hienxsktdakla`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}