const regex = /^[a-z][a-z0-9_\.]{5,32}@[a-z0-9]{2,}(?:\.[a-z0-9]{2,4}){1,2}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z][a-z0-9_\\.]{5,32}@[a-z0-9]{2,}(?:\\.[a-z0-9]{2,4}){1,2}$', 'gm')
const str = `longvu.kiemtien@gmail.com
00tk.quangphuong@gmail.com
nguyentangchien@mail.com
samsam052001@
buithianhthu2612@gmail.com
khanhhn.games@gmail
hienxsktdakla`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}