import Foundation
// WARNING: You included a flag that Swift doesn't support: D
// When this flag is set, it forces the a dollar sign ('$'), to always match end of the string, instead of end of the line. This option is ignored if the 'm' flag is set.
// There's no equivalent implementation of this flag in Swift, but you may want to check the 'm' flag instead.
let pattern = #"^(?:\d+|[a-zA-Z]+)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"12344"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}