using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(a|h1)[^\>]*?>(some)[^\<]*?<\/\1>";
string input = @"<p>
<h1>Some header, which I don't want to match</h1>
Some text - match it.
<a href=""some-file.html"">Some link. Don't match neither href nor link text.</a>
<span>Some word, which needs to be matched</span>
</p>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}