import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(a|h1)[^\\>]*?>(some)[^\\<]*?<\\/\\1>";
final String string = "<p>\n"
+ " <h1>Some header, which I don't want to match</h1>\n"
+ " Some text - match it.\n"
+ " <a href=\"some-file.html\">Some link. Don't match neither href nor link text.</a>\n"
+ " <span>Some word, which needs to be matched</span>\n"
+ "</p>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}