using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"PV\{(\d+?(?:\.\d+){0,3})\}";
string input = @"PV{9}
PV{9.9}
PV{9.9.9}
PV{9.9.9.9}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}