package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:<[^<>]*>|<.*?>)*.){9}`)
var str = `Some <i>t</i>est <b>string</b> test
Some <i>t</i>est <b>string</b> test`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}