re = /^(?:(?:<[^<>]*>|<.*?>)*.){9}/m
str = 'Some <i>t</i>est <b>string</b> test
Some <i>t</i>est <b>string</b> test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end