#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0-9]*(?:,[0-9]{3})*\.[0-9]{2}$"
Local $sString = "Allow" & @CRLF & _
"" & @CRLF & _
"100,000.12" & @CRLF & _
"" & @CRLF & _
"10,000.12" & @CRLF & _
"" & @CRLF & _
"1,000.12" & @CRLF & _
"" & @CRLF & _
"100.12" & @CRLF & _
"" & @CRLF & _
"10.12" & @CRLF & _
"" & @CRLF & _
".12" & @CRLF & _
"" & @CRLF & _
"Don't allow" & @CRLF & _
"" & @CRLF & _
"abcd" & @CRLF & _
"" & @CRLF & _
"1,,000.12" & @CRLF & _
"" & @CRLF & _
"1,00.12" & @CRLF & _
"" & @CRLF & _
"1,000.0" & @CRLF & _
"" & @CRLF & _
"1,000."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")