use strict;
my $str = '+48301234567
+4-8-3-0-1-2-3-4-5-6-7
+48/30/1234567
+48-30-12-345-67
+483011223344556677
0048301234567
+(48)30/1234567';
my $regex = qr/(?=^(?:\+|00)?(?:[\-\/\(\)]?\d){11}$)(?:00|\+)[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])[^\d]*([\d])$/mp;
my $subst = '+(\\1\\2) \\3\\4/\\5\\6-\\7\\8\\9-\\10\\11';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";