using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[0-3]|[6-9])[0-9]*|[54]\d{4,}$";
string input = @"1500
26489
212
15849
5000
5001
4584
2402
5191981
4618916
6540
4500
45000
9999999
4001
4000
3999
5999
6000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}