using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!(.*?C){2})[ABC]{3}";
string input = @"ABC
ACB
CBA
BCA
AAB
ABA
BAA
AAC
ACA
CAA
ABB
BAB
BBA
BBB
CCC
CCA
CAC
ACC
CCB
CBC
BCC
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}