use strict;
my $str = 'ABC
ACB
CBA
BCA
AAB
ABA
BAA
AAC
ACA
CAA
ABB
BAB
BBA
BBB
CCC
CCA
CAC
ACC
CCB
CBC
BCC
';
my $regex = qr/(?!(.*?C){2})[ABC]{3}/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}