$re = '/(?!(.*?C){2})[ABC]{3}/i';
$str = 'ABC
ACB
CBA
BCA
AAB
ABA
BAA
AAC
ACA
CAA
ABB
BAB
BBA
BBB
CCC
CCA
CAC
ACC
CCB
CBC
BCC
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);