re = /(?!(.*?C){2})[ABC]{3}/i
str = 'ABC
ACB
CBA
BCA
AAB
ABA
BAA
AAC
ACA
CAA
ABB
BAB
BBA
BBB
CCC
CCA
CAC
ACC
CCB
CBC
BCC
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end