# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/>{\d+}</></g;t' <<< "<Financials>
<IncomeStatement>
<Revenue>{0}</Revenue>
<OperatingIncome>{1}</OperatingIncome>
<NetIncome>{2}</NetIncome>
<BasicEPS>{3}</BasicEPS>
<AvgSharesOutstand>{4}</AvgSharesOutstand>
</IncomeStatement>
<BalanceSheet>
<CurrentAssets>{5}</CurrentAssets>
<NonCurrentAssets>{6}</NonCurrentAssets>
<TotalAssets>{7}</TotalAssets>
<CurrentLiabilities>{8}</CurrentLiabilities>
<TotalLiabilities>{9}</TotalLiabilities>
<TotalEquity>{10}</TotalEquity>
</BalanceSheet>
<CashFlow>
<OperatingCashFlow>{11}</OperatingCashFlow>
<CapitalExpenditure>{12}</CapitalExpenditure>
<FreeCashFlow>{13}</FreeCashFlow>
</CashFlow>
</Financials>"