# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r">{\d+}<"
test_str = ("<Financials>\n"
" <IncomeStatement>\n"
" <Revenue>{0}</Revenue>\n"
" <OperatingIncome>{1}</OperatingIncome>\n"
" <NetIncome>{2}</NetIncome>\n"
" <BasicEPS>{3}</BasicEPS>\n"
" <AvgSharesOutstand>{4}</AvgSharesOutstand>\n"
" </IncomeStatement>\n"
" <BalanceSheet>\n"
" <CurrentAssets>{5}</CurrentAssets>\n"
" <NonCurrentAssets>{6}</NonCurrentAssets>\n"
" <TotalAssets>{7}</TotalAssets>\n"
" <CurrentLiabilities>{8}</CurrentLiabilities>\n"
" <TotalLiabilities>{9}</TotalLiabilities>\n"
" <TotalEquity>{10}</TotalEquity>\n"
" </BalanceSheet>\n"
" <CashFlow>\n"
" <OperatingCashFlow>{11}</OperatingCashFlow>\n"
" <CapitalExpenditure>{12}</CapitalExpenditure>\n"
" <FreeCashFlow>{13}</FreeCashFlow>\n"
" </CashFlow>\n"
"</Financials>")
subst = "><"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.